aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 425117f..c74d615 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,6 +18,13 @@ add_library(libxbouncing
include(FindX11)
+IF (NOT X11_FOUND)
+ MESSAGE(FATAL_ERROR "X11 not found.")
+ENDIF()
+IF (NOT X11_Xrandr_FOUND)
+ MESSAGE(FATAL_ERROR "Xrandr not found.")
+ENDIF()
+
add_executable(xbouncing src/xbouncing.c)
add_executable(parse-xbm src/parse-xbm.c)
target_link_libraries(parse-xbm libxbouncing)