aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Timber <dxdt@dev.snart.me>2024-11-01 02:44:07 +0100
committerDavid Timber <dxdt@dev.snart.me>2024-11-01 02:44:07 +0100
commit8bf50e5b8daa3ac21e6b4e3035511a75f8887a7c (patch)
treebb9d6e42f719f593e319adb77354e2391c9b3059 /CMakeLists.txt
parent4add40e55c40fefc8fd083eb4700b05630899ec2 (diff)
Add lib checks, other changes ...
- Add libX11 and libXrandr checks in cmake - Limit refresh rate to 60 - Call XFlush() before sleeping in main_loop() - Shorter XOpenDisplay() error message - print the troubleshoot suggestions in the script
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 425117f..c74d615 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,6 +18,13 @@ add_library(libxbouncing
include(FindX11)
+IF (NOT X11_FOUND)
+ MESSAGE(FATAL_ERROR "X11 not found.")
+ENDIF()
+IF (NOT X11_Xrandr_FOUND)
+ MESSAGE(FATAL_ERROR "Xrandr not found.")
+ENDIF()
+
add_executable(xbouncing src/xbouncing.c)
add_executable(parse-xbm src/parse-xbm.c)
target_link_libraries(parse-xbm libxbouncing)