aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Timber <dxdt@dev.snart.me>2024-10-31 17:51:07 +0100
committerDavid Timber <dxdt@dev.snart.me>2024-10-31 18:55:51 +0100
commit364f388c2aaa92094785b0bfca4ec6bfb9207737 (patch)
tree92301a265b95ae5f7fadf57800fc5286ab379cc4 /CMakeLists.txt
parent1e0496b6676b30642305e09f6f7dbe7966f87f0e (diff)
Add install target, spec cmake project lang
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1acd219..425117f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.10)
-project(xbouncing VERSION 0.0.0)
+project(xbouncing VERSION 0.0.0 LANGUAGES C)
set(CMAKE_C_STANDARD 11)
set(CMAKE_C_STANDARD_REQUIRED True)
@@ -22,3 +22,4 @@ add_executable(xbouncing src/xbouncing.c)
add_executable(parse-xbm src/parse-xbm.c)
target_link_libraries(parse-xbm libxbouncing)
target_link_libraries(xbouncing libxbouncing ${X11_LIBRARIES} ${X11_Xrandr_LIB} m)
+install(TARGETS xbouncing)