aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDavid Timber <dxdt@dev.snart.me>2024-08-28 14:08:09 +0200
committerDavid Timber <dxdt@dev.snart.me>2024-08-28 14:10:16 +0200
commit1e0496b6676b30642305e09f6f7dbe7966f87f0e (patch)
tree1de4fa0052963cbea242275cc261ae4105a8ebcb /CMakeLists.txt
Initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..1acd219
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,24 @@
+cmake_minimum_required(VERSION 3.10)
+
+project(xbouncing VERSION 0.0.0)
+
+set(CMAKE_C_STANDARD 11)
+set(CMAKE_C_STANDARD_REQUIRED True)
+
+configure_file(
+ src/config.h.in
+ ${CMAKE_BINARY_DIR}/config.h)
+
+add_compile_options(-Wall -Wextra)
+
+add_library(libxbouncing
+ ${CMAKE_BINARY_DIR}/config.h
+ src/xbm.c
+)
+
+include(FindX11)
+
+add_executable(xbouncing src/xbouncing.c)
+add_executable(parse-xbm src/parse-xbm.c)
+target_link_libraries(parse-xbm libxbouncing)
+target_link_libraries(xbouncing libxbouncing ${X11_LIBRARIES} ${X11_Xrandr_LIB} m)