aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 4d1f95f..5f310b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,22 +20,6 @@ esac],
[debug=false])
AM_CONDITIONAL(DEBUG, test x"$debug" = x"true")
-AC_ARG_ENABLE(tests,
-AS_HELP_STRING([--enable-tests],
- [build tests, default: no]),
-[case "${enableval}" in
- yes) tests=true ;;
- no) tests=false ;;
- *) AC_MSG_ERROR([bad value ${enableval} for --enable-tests]) ;;
-esac],
-[tests=false])
-AM_CONDITIONAL(TESTS, test x"$tests" = x"true")
-# AM_COND_IF([TESTS], [
-# AC_CHECK_HEADERS([gtest/gtest.h],
-# [],
-# [AC_MSG_ERROR([gtest/gtest.h not found.])])
-# ])
-
AC_CHECK_LIB([pthread], [pthread_create], [], [AC_MSG_ERROR([pthread not found])])
AC_CHECK_LIB([rt], [shm_open], [], [AC_MSG_ERROR([rt not found])])
AC_CHECK_LIB([z], [zlibVersion], [], [AC_MSG_ERROR([zlib not found])])