aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Timber <mieabby@gmail.com>2020-08-20 12:23:35 +0930
committerDavid Timber <mieabby@gmail.com>2020-08-20 15:15:57 +0930
commit76d4d6b2bafada7b790e817b7324d53f3d3a0c7f (patch)
treed8b3669fa7b167fc3bf764e971fc6e70bd8d9b49 /configure.ac
parent7bd3eb3b1ad4209ac4cf4b46f849213d46bc33aa (diff)
Progress ...
* Move DVault out of executable. Dynamically load it on startup * Improved testing scheme * Tidy up prne_*assert* macro series * Protocol: store host credentials in base64 string. No mask * Use the lock shm as a shared_global so the stats can persist * mmap() the executable read-only for later use
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 4d1f95f..5f310b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,22 +20,6 @@ esac],
[debug=false])
AM_CONDITIONAL(DEBUG, test x"$debug" = x"true")
-AC_ARG_ENABLE(tests,
-AS_HELP_STRING([--enable-tests],
- [build tests, default: no]),
-[case "${enableval}" in
- yes) tests=true ;;
- no) tests=false ;;
- *) AC_MSG_ERROR([bad value ${enableval} for --enable-tests]) ;;
-esac],
-[tests=false])
-AM_CONDITIONAL(TESTS, test x"$tests" = x"true")
-# AM_COND_IF([TESTS], [
-# AC_CHECK_HEADERS([gtest/gtest.h],
-# [],
-# [AC_MSG_ERROR([gtest/gtest.h not found.])])
-# ])
-
AC_CHECK_LIB([pthread], [pthread_create], [], [AC_MSG_ERROR([pthread not found])])
AC_CHECK_LIB([rt], [shm_open], [], [AC_MSG_ERROR([rt not found])])
AC_CHECK_LIB([z], [zlibVersion], [], [AC_MSG_ERROR([zlib not found])])