aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Timber <mieabby@gmail.com>2021-07-12 16:16:22 +1000
committerDavid Timber <mieabby@gmail.com>2021-07-12 16:16:22 +1000
commit15bde4c46b707f7a95c7ea6650a3f02d67e50530 (patch)
tree1aa069521941a41171302dba837d57d35a2d9e41 /src/Makefile.am
parent3fbf08ab6522c91e8209b21d66430a2db4ea71cb (diff)
Impl proone-htbtclient, bugfix, --enable-mttools
* Remove --enable-hostinfod and add --enable-mttools, which enables hostinfod and htbtclient * Change PRNE_HTBT_PROTO_PORT so that the macro can be used in another macro expression(for help message) * Add prne_mbedtls_perror() * proone-htbtclient: implement hostinfo command * proone-htbthost * Add --hostcred option * Response with status frame on ENOMEM * htbt: add prne_htbt_serrc_tostr() and prne_htbt_gen_msgid() * Add prne_ctoupper(), prne_ctolower(), prne_cisspace(), prne_cisprint() * The added functions are the locale-independent equivalent of their POSIX counterparts * Remove Use of the POSIX functions * Add test unit
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 92ef99c..8666f2b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -45,8 +45,8 @@ bin_PROGRAMS =\
proone-recon\
proone-mkcdict\
proone-bne
-if BUILD_HOSTINFOD
-bin_PROGRAMS += proone-hostinfod
+if BUILD_MTTOOLS
+bin_PROGRAMS += proone-hostinfod proone-htbtclient
endif
proone_tests =\
@@ -127,9 +127,11 @@ proone_bne_SOURCES = proone-bne.c
proone_recon_LDADD = libproone.a
proone_recon_SOURCES = proone-recon.c
-if BUILD_HOSTINFOD
+if BUILD_MTTOOLS
proone_hostinfod_LDADD = libproone.a
proone_hostinfod_SOURCES = proone-hostinfod.c
+proone_htbtclient_LDADD = libproone.a
+proone_htbtclient_SOURCES = proone-htbtclient.c
endif
proone_test_proto_LDADD = libproone.a