aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDavid Timber <mieabby@gmail.com>2020-09-08 19:46:44 +0930
committerDavid Timber <mieabby@gmail.com>2020-09-08 20:10:57 +0930
commit0e512e6ae3146fcf3ce2427c8c36937d708d149b (patch)
tree40a6ad8c64b419e2f8d0bcc289e9608852ff76ae /src/Makefile.am
parent550d2eec27a42254b26139208765022fffe7c775 (diff)
* Fix bug in pth_poll: wrong use of FD_SET()
causing undefined behaviour * Fix bug in proone: loading ns pool from dvault for resolv * Fix bug in htbt: improper handling of stream in htbt_relay_child() * Switch back to _POSIX_C_SOURCE=200112L
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e138e87..8b6369d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,6 @@
BIN_ALIGNMENT = 8
-AM_CFLAGS = -std=c11 -pedantic -Wall -Wextra -Wno-switch -D_POSIX_C_SOURCE=199506L -Wno-unused-parameter -DPRNE_BIN_ALIGNMENT=$(BIN_ALIGNMENT) -fdata-sections -ffunction-sections -Wl,--gc-sections
+AM_CFLAGS = -std=c11 -pedantic -Wall -Wextra -Wno-switch -D_POSIX_C_SOURCE=200112L -Wno-unused-parameter -DPRNE_BIN_ALIGNMENT=$(BIN_ALIGNMENT) -fdata-sections -ffunction-sections -Wl,--gc-sections
if DEBUG
AM_CFLAGS += -g -O0 -DPRNE_DEBUG
else