aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Timber <mieabby@gmail.com>2020-08-10 19:25:43 +0930
committerDavid Timber <mieabby@gmail.com>2020-08-11 11:01:49 +0930
commitd7cc11191dfd3fead5e596fcbc24f40d1317819e (patch)
tree4f52b450bf499fe6721a944f2e9cd41cb1e17828 /configure.ac
parent195946d11f8a7870b435e0eba32f2299aa1b96a1 (diff)
Build system change, bugfix ...
* Workaround for a bug where getrandom() call block within mbedtls * Remove use of undocumented autoconf feature: pkg-config * Remove proone-arch-test
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 24eb7c8..4d1f95f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,7 +36,9 @@ AM_CONDITIONAL(TESTS, test x"$tests" = x"true")
# [AC_MSG_ERROR([gtest/gtest.h not found.])])
# ])
-PKG_CHECK_MODULES_STATIC([DEP_PKGCFG], [zlib])
+AC_CHECK_LIB([pthread], [pthread_create], [], [AC_MSG_ERROR([pthread not found])])
+AC_CHECK_LIB([rt], [shm_open], [], [AC_MSG_ERROR([rt not found])])
+AC_CHECK_LIB([z], [zlibVersion], [], [AC_MSG_ERROR([zlib not found])])
AC_CHECK_LIB([mbedcrypto], [mbedtls_cipher_setup], [], [AC_MSG_ERROR([mbedtls not found])])
AC_CHECK_LIB([mbedtls], [mbedtls_ssl_init], [], [AC_MSG_ERROR([mbedtls not found])])
AC_CHECK_LIB([mbedx509], [mbedtls_x509_crt_parse], [], [AC_MSG_ERROR([mbedtls not found])])