aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Timber <mieabby@gmail.com>2020-09-08 20:44:56 +0930
committerDavid Timber <mieabby@gmail.com>2020-09-08 20:44:56 +0930
commit192388b2c5dfe5df6f0d2654a6705778a6c9d90c (patch)
treef8caa7b130a40f29cdc44f73f7fd2a28f61bf57f /configure.ac
parent0e512e6ae3146fcf3ce2427c8c36937d708d149b (diff)
Add check for tools needed to build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 038810b..c23cd49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,12 @@ AC_CHECK_LIB([mbedtls], [mbedtls_ssl_init], [], [AC_MSG_ERROR([mbedtls not found
AC_CHECK_LIB([mbedx509], [mbedtls_x509_crt_parse], [], [AC_MSG_ERROR([mbedtls not found])])
AC_CHECK_LIB([pthsem], [pth_init], [], [AC_MSG_ERROR([pthsem not found])])
+AC_CHECK_PROG(TOOL_XXD, [xxd], [yes])
+AS_IF([test x"$TOOL_XXD" != x"yes"], [AC_MSG_ERROR([xxd not found])])
+AC_CHECK_PROG(TOOL_SED, [sed], [yes])
+AS_IF([test x"$TOOL_SED" != x"yes"], [AC_MSG_ERROR([sed not found])])
+
+
AC_DEFINE_UNQUOTED(
[PRNE_BUILD_ENTROPY],
[{ $(xxd -l16 -ps /dev/urandom | sed -E s/\(\\S{2}\)/0x\&,\ /g | sed -E s/,\ \$//) }])